Partial platform outage affecting users
Incident Report for Along
Resolved
All teachers should be able to access all pages on Along. Thank you again for your patience. If you have any questions, please reach out to our Help Desk at support@along.org.
Posted Mar 27, 2024 - 00:07 UTC
Monitoring
You should now be able to access all pages on Along. We’ll continue to closely monitor to ensure there are no further issues.
Posted Mar 26, 2024 - 18:40 UTC
Investigating
Along is currently experiencing higher-than-normal server usage and this may be causing pages to be slow or unresponsive.

We’re sorry for the inconvenience and are working to get this fixed. We’ll update you within one hour with the latest information.
Posted Mar 26, 2024 - 17:39 UTC
This incident affected: Teacher App and Student App.