Issues Logging Into Along

Incident Report for Along

Resolved

Resolved! Teachers and students can now log into Along as expected.
Posted May 29, 2025 - 23:43 UTC

Investigating

Some teachers and students are unable to log into Along. We’re aware of the issue and are working on it urgently.
Posted May 29, 2025 - 22:04 UTC
This incident affected: Teacher App, Student App, and Google Apps Gmail.